• Business
  • Design
  • Free
  • Interesting
  • mascot design
  • Resources
  • SEO
  • Web Design
  • Web Development
  • Wordpress
  • Switching between WordPress Visual and HTML editor not working

    By Danno

    Heh.  I just got done posting a quick shout to Jean-Baptiste for his excellent Sliding Doors + WordPress technique when I realized it had happened again: The Visual and HTML tabs on the WordPress text editor were broken again.  I don’t know of any permanent fixes, but if this happens to you here’s how you can fix the issue temporarily:

    • Log into your WordPress admin
    • Go to Design > Themes
    • Switch / activate any other theme than your current one (I just use the Default)
    • Go to Write > Post (as if you are about to write a new post)
    • You should see the GUI for the editor restored and be able to switch between Visual and HTML modes once more
    • Go back to Design > Themes and reactivate your desired theme

    If that doesn’t work … I have NFI.

    Be Sociable, Share!

    More...

    About the author

    Danno started freelancing in 1996. He is the co-founder and (ex) President of Graphics.net, owner of FeedIcons.com, EliteFreelancing.com, FastCharacters.com and SteelAndSnow.com. He digs wind, waves, guitars and circles. Follow Danno on Twitter.

    Comments on this article...

    • dylan_k:

      I have had this same glitch happen with WordPress 2.6.3. The fix you've described here has not worked for me. Switching to the default theme made the problem go away but… Once I went back to the first theme, the promlem returned.

    • dylan_k:

      Make sure your theme's functions.php file is well formed. I was able to correct this issue by editing my theme's functions.php file. Removing blank lines helped.

    • nella:

      I have also had the same problem, you can read the solution I found here:
      http://www.csnotes.net/?p=31

      it worked in my case :)

    • entiltsuitica:

      ATLANTA – Since it from the start emerged in April, the universal swine flu epidemic has sickened more than 1 million Americans and killed about 500. It’s also spread everywhere the coterie, infecting tens of thousands and slaughter wellnigh 2,000.

      This summer, the virus has been surprisingly tenacious in the U.S., levitra plus online refusing to cloud over away as flu viruses in the main do. And constitution officials forewarn a rush of cases this fall, it is possible that uncommonly directly as schools reopen.

    • Talya:

      I have the same problem in my web hosting blog (WordPress 2.8.5). I can switch but both visual and html show the same.

    • trevor:

      Thanks for the help, it worked for me!

      Trevor

    • Madox:

      Hi thank you very much iy worked for me too … i spent a month trying to fix it
      in the last step when you click visual just wait some seconds

    • xformed:

      I had recently put an .htaccess file in my wp-includes to allow more memory for the php functions, because I was getting errors with so many plugins.

      IThought…what the heck, so I went in and renamed that .htacess to something benign and now my WYSIWYG editor is back!

      Worked on both of my blogs (which I had patched for the same reason….

    • juanpablo:

      i have the same issue however the problem only occurs within my homepage/mainpage. In all other pages/posts, i can switch between visual and html.

      any ideas why the bug only applies to my homepage?

    • Angelverde:

      ¡No funciona!

    • mirabelle:

      Doesn't work :(

    • Gary:

      I had this problem tonight, and it turned out to be one of my plug-ins! Check those first! Try maybe disable one at a time to see if you can get a fix!

    • gijs:

      Yeah, i had it on a nearly finished website! Turned out to be my latest installed plug-in wp-database backup. Deactivated the plugin and everyting is fine again.

    • Robbie:

      I still have the problem with 3.0.1! Does anyone know the problem, do you think it is a plugin, as my cover letter site can't enter html mode?

    • George:

      This is extremely frustrating. Anyone with an idea about this? I tried all solution mentioned here, I turned off all my plugins, I re-installed WP 3.01, I removed empty lines from the function.php file, i switched to the twenty ten default theme and back to my theme and now I'm out of ideas. The visual editor just doesn't turn back on. Heeelp!